MENU

Migration vers les nouveaux serveurs web

, par b_b

Des nouveaux serveurs web pour de meilleurs performances et une stabilité accrue !

Les bénévoles de l’équipe technique ont travaillé dur sur les serveurs web ces derniers temps. Cela nous permet maintenant de vous proposer plusieurs versions de PHP pour propulser vos sites dynamiques. À ce jour, 3 versions de PHP sont disponibles : les versions 7.2, 5.6 et 5.4.

Cette dernière version sera très prochainement abandonnée car elle n’est plus maintenue et peut présenter des problèmes de sécurité. Nous vous demandons donc de migrer rapidement vers l’une ou l’autre des 2 versions suivantes : 7.2 ou 5.6.

Ces nouveaux serveurs sont prêts à accueillir vos sites ! Ils nous permettent d’avoir une meilleur visibilité sur leur bon fonctionnement et d’être plus réactifs en cas d’incident. Nous vous invitons à migrer rapidement vers ceux-ci !

La procédure de migration est accessible depuis votre espace de gestion sur le panel alternc, modifiez le ou les domaines que vous souhaitez migrer et de sélectionnez l’une des 2 nouvelles versions disponible (5.6 ou 7.2) .

Consultez la documentation "Choix de la version de PHP" pour plus de détail sur cette procédure. Essayez sans risque, si votre site n’est pas fonctionnel après vous pouvez revenir en version 5.4.

Si vous ne savez pas quelle version de PHP choisir, voici quelques conseils :

  • si vous utilisez un système de gestion de contenu comme SPIP, Wordpress ou Mediawiki, et que celui-ci est à jour, vous pouvez sereinement choisir PHP 7.2, les performances d’affichage des pages de votre site devraient être bien meilleures ;
  • si vous utiliser un site contenant des bidouilles personnelles et que vous ne savez pas quelle version choisir, choisissez PHP 5.6 et consultez les guides de mise à jour de PHP 5.5 et PHP 5.6, ça devrait bien se passer, les incompatibilités ne sont pas nombreuses.

Pour information, les anciens serveurs qui hébergent les sites sous PHP 5.4 seront bientôt éteints. Nous procéderons donc à une migration automatique de vos sites (si vous ne l’avez pas déjà fait) vers les nouveaux serveurs sous PHP 5.6 à partir du 19 novembre 2019.

ADDENDUM : si vous utilisez SPIP ou Mediawiki, vous pouvez vérifier la compatibilité de votre version avec les différentes versions de PHP :

Nous vous rappelons que pour lutter contre le piratage, il est important que votre site soit à jour !